bash:pip:找不到命令

问题: 我下载了pip并运行了python设置.py安装一切正常。本教程的下一步是运行pip install<lib you want>,但在它尝试联机查找任何内容之前,我会收到一个错误“bash:pip:command not found” 这是在macosx上,我也是新的,所以我假设有某种路径设置在我运行时没有正确设置设置.py. 我如何进一步调查?我需要检查什么才能更好地了解问题

详情

如何在Ubuntu上通过pip安装python3版本的包?

问题: 我把python2.7和python3.2都安装在了ubuntu12.04中 当我键入: sudo pip install package-name 它将默认安装python2版本的包名 有些包同时支持python2和python3 答案: 您可能需要构建python3的virtualenv,然后在激活virtualenv之后安装python3的包。这样你的系统就不会乱套了:) 可能是这样

详情

使用pip将Python包安装到另一个目录中?

问题: 我知道显而易见的答案是使用virtualenv和virtualenvwrapper,但由于种种原因,我不能/不想这样做 那么如何修改命令呢 pip install package_name 要使pip将包安装到默认的站点包之外的其他地方?在 答案: 使用: pip install –install-option=”–prefix=$PREFIX_PATH” package_name 您

详情

Python和pip,列出所有可用的包版本?

问题: 给定可以与一起安装的Python包的名称pip,有没有办法找出pip可以安装的所有可能版本的列表?现在是试错 我正在尝试为第三方库安装一个版本,但最新版本太新,有向后不兼容的更改。所以我想以某种方式列出pip知道的所有版本,这样我就可以测试它们了 答案: (更新:截至2020年3月,许多人报告通过pip install yolk3k安装的yolk只返回最新版本。Chris’s answer

详情

正在删除pip的缓存?

问题: 我需要专门安装psycopg2v2.4.1。我不小心做了: pip install psycopg2 而不是: pip install psycopg2==2.4.1 它将安装2.4.4而不是早期版本。在 现在,即使在我pip卸载psycopg2并尝试用正确的版本重新安装之后,pip似乎仍在重新使用它第一次下载的缓存 如何强制pip清除其下载缓存并使用我在命令中包含的特定版本?在 答案:

详情

如何陈述要求.txt直接github源

问题: 我用命令安装了一个库 pip install git+git://github.com/mozilla/elasticutils.git 它直接从Github存储库安装它。这很好,我希望在我的中有这种依赖性要求.txt。我看过其他的票this但这并没有解决我的问题。如果我把 -f git+git://github.com/mozilla/elasticutils.gitelasticuti

详情

没有名为pkg_resources的模块

问题: 我正在将一个Django应用部署到一个dev服务器上,当我运行pip install-r时遇到了这个错误要求.txt: Traceback (most recent call last): File “/var/www/mydir/virtualenvs/dev/bin/pip”, line 5, in <module> from pkg_resources import lo

详情

处理多个Python版本和PIP?

问题: 有没有办法让pip在Python的多个版本上运行得很好?例如,我想使用pip将东西显式安装到我的site2.5安装或site2.6安装中 例如,对于easy-install,我使用easy\u install-2.{5,6} 而且,是的,我知道virtualenv,不,它不是解决这个问题的方法 答案: 在current recommendation是使用python-mpip,其中pyth

详情