我可以强制pip重新安装当前版本吗?

问题: 我遇到过这样的情况:当前版本的软件包似乎不起作用,需要重新安装。但是pip install-U不会触及已经更新的包。我知道如何通过先卸载(使用pip uninstall)然后安装来强制重新安装,但是有没有一种方法可以在一个步骤中简单地强制“更新”到名义上的当前版本?在 答案: pip install –upgrade –force-reinstall <package> 升

详情

如何删除与Python的easy\u安装一起安装的包?

问题: Python的轻松安装使安装新软件包非常方便。然而,据我所知,它并没有实现依赖关系管理器的其他常见功能—列出并删除已安装的包 找出已安装软件包的最佳方法是什么?删除已安装软件包的首选方法是什么?如果我手动删除包,是否有需要更新的文件(例如通过rm/usr/local/lib/python2.6/dist-packages/my_installed_包装鸡蛋或类似的?在 答案: 在pip作为

详情